Linux @ CERN

CERN > IT > Linux

"SLC6X: applications/publishing: ghostscript

ghostscript - A PostScript interpreter and renderer

Website: http://www.ghostscript.com/
License: GPLv3+ and Redistributable, no modification permitted
Vendor: Scientific Linux CERN, http://cern.ch/linux
Description:
Ghostscript is a set of software that provides a PostScript
interpreter, a set of C procedures (the Ghostscript library, which
implements the graphics capabilities in the PostScript language) and
an interpreter for Portable Document Format (PDF) files. Ghostscript
translates PostScript code into many common, bitmapped formats, like
those understood by your printer or screen. Ghostscript is normally
used to display PostScript files and to print PostScript files to
non-PostScript printers.

If you need to display PostScript files or print them to
non-PostScript printers, you should install ghostscript. If you
install ghostscript, you also need to install the ghostscript-fonts
package.

Packages

ghostscript-8.70-23.el6_9.2.i686 [4.5 MiB] Changelog by David Kaspar [Dee'Kej] (2017-05-11):
- Security fix for CVE-2017-8291 updated to address SIGSEGV
ghostscript-8.70-23.el6_9.2.x86_64 [4.4 MiB] Changelog by David Kaspar [Dee'Kej] (2017-05-11):
- Security fix for CVE-2017-8291 updated to address SIGSEGV
ghostscript-8.70-23.el6.x86_64 [4.4 MiB] Changelog by David Kaspar [Dee'Kej] (2017-01-31):
- Fix for regression caused by previous CVE fixes (bug #1410260)
ghostscript-8.70-23.el6.i686 [4.5 MiB] Changelog by David Kaspar [Dee'Kej] (2017-01-31):
- Fix for regression caused by previous CVE fixes (bug #1410260)
ghostscript-8.70-21.el6_8.1.i686 [4.5 MiB] Changelog by David Kaspar [Dee'Kej] (2016-11-07):
- Added security fixes for:
  - CVE-2013-5653 (bug #1380327)
  - CVE-2016-7977 (bug #1380415)
  - CVE-2016-7979 (bug #1382305)
  - CVE-2016-8602 (bug #1383940)
ghostscript-8.70-21.el6_8.1.x86_64 [4.4 MiB] Changelog by David Kaspar [Dee'Kej] (2016-11-07):
- Added security fixes for:
  - CVE-2013-5653 (bug #1380327)
  - CVE-2016-7977 (bug #1380415)
  - CVE-2016-7979 (bug #1382305)
  - CVE-2016-8602 (bug #1383940)
ghostscript-8.70-21.el6.x86_64 [4.4 MiB] Changelog by Tim Waugh (2015-02-20):
- Removed patch backup file from payload (bug #1027534).
ghostscript-8.70-21.el6.i686 [4.5 MiB] Changelog by Tim Waugh (2015-02-20):
- Removed patch backup file from payload (bug #1027534).
ghostscript-8.70-19.el6.x86_64 [4.4 MiB] Changelog by Tim Waugh (2013-09-13):
- Removed patch backup file from payload.
ghostscript-8.70-19.el6.i686 [4.5 MiB] Changelog by Tim Waugh (2013-09-13):
- Removed patch backup file from payload.
ghostscript-8.70-15.el6_4.1.x86_64 [4.4 MiB] Changelog by Tim Waugh (2013-03-08):
- Back-ported patch to copy CIDFontType 2 properly (bug #893775).
ghostscript-8.70-15.el6_4.1.i686 [4.4 MiB] Changelog by Tim Waugh (2013-03-08):
- Back-ported patch to copy CIDFontType 2 properly (bug #893775).
ghostscript-8.70-14.el6_3.1.x86_64 [4.4 MiB] Changelog by Tim Waugh (2012-09-06):
- Added inputChan lower-bounds checking to icclib (bug #854227,
  CVE-2012-4405).
ghostscript-8.70-14.el6_3.1.i686 [4.4 MiB] Changelog by Tim Waugh (2012-09-06):
- Added inputChan lower-bounds checking to icclib (bug #854227,
  CVE-2012-4405).
ghostscript-8.70-14.el6.x86_64 [4.4 MiB] Changelog by Tim Waugh (2012-03-06):
- Fixed character spacing problems using backported patch (bug #695766).
- Apply some fixes from upstream to avoid gdevcups segfaults (bug #643105).
ghostscript-8.70-14.el6.i686 [4.4 MiB] Changelog by Tim Waugh (2012-03-06):
- Fixed character spacing problems using backported patch (bug #695766).
- Apply some fixes from upstream to avoid gdevcups segfaults (bug #643105).
ghostscript-8.70-11.el6_2.6.x86_64 [4.4 MiB] Changelog by Tim Waugh (2011-12-21):
- Applied upstream fix to last patch (CVE-2010-4054, bug #646086).
ghostscript-8.70-11.el6_2.6.i686 [4.4 MiB] Changelog by Tim Waugh (2011-12-21):
- Applied upstream fix to last patch (CVE-2010-4054, bug #646086).
ghostscript-8.70-11.el6_1.2.x86_64 [4.4 MiB] Changelog by Tim Waugh (2011-05-31):
- Use landscape PXL page sizes when appropriate (bug #710651).
ghostscript-8.70-11.el6_1.2.i686 [4.4 MiB] Changelog by Tim Waugh (2011-05-31):
- Use landscape PXL page sizes when appropriate (bug #710651).
ghostscript-8.70-11.el6.x86_64 [4.4 MiB] Changelog by Tim Waugh (2011-03-24):
- Fixed generation of hyperlinks in ps2pdf (bug #675692).
ghostscript-8.70-11.el6.i686 [4.4 MiB] Changelog by Tim Waugh (2011-03-24):
- Fixed generation of hyperlinks in ps2pdf (bug #675692).

Listing created by repoview