Linux @ CERN

CERN > IT > Linux

"SLC6X: system environment/base: pki-util

pki-util - Certificate System - PKI Utility Framework

Website: http://pki.fedoraproject.org/
License: GPLv2
Vendor: Scientific Linux CERN, http://cern.ch/linux
Description:
The PKI Utility Framework is required by the following four PKI subsystems:

    the Certificate Authority (CA),
    the Data Recovery Manager (DRM),
    the Online Certificate Status Protocol (OCSP) Manager, and
    the Token Key Service (TKS).

This package is a part of the PKI Core used by the Certificate System.


==================================
||  ABOUT "CERTIFICATE SYSTEM"  ||
==================================

Certificate System (CS) is an enterprise software system designed
to manage enterprise Public Key Infrastructure (PKI) deployments.

PKI Core contains fundamental packages required by Certificate System,
and consists of the following components:

  * pki-setup
  * pki-symkey
  * pki-native-tools
  * pki-util
  * pki-util-javadoc
  * pki-java-tools
  * pki-java-tools-javadoc
  * pki-common
  * pki-common-javadoc
  * pki-selinux
  * pki-ca
  * pki-silent

which comprise the following PKI subsystems:

  * Certificate Authority (CA)

For deployment purposes, Certificate System requires ONE AND ONLY ONE
of the following "Mutually-Exclusive" PKI Theme packages:

  * ipa-pki-theme    (IPA deployments)
  * dogtag-pki-theme (Dogtag Certificate System deployments)
  * redhat-pki-theme (Red Hat Certificate System deployments)

Packages

pki-util-9.0.3-53.el6.noarch [496 KiB] Changelog by Endi S. Dewata (2017-02-08):
- Resolves #1403943 - Replica install fails with failed to configure ca on
  "White spaces are required between publicId and systemId"
  (contains the additional changes required to work with the latest HTTPD)
pki-util-9.0.3-50.el6_8.noarch [495 KiB] Changelog by Matthew Harmsen (2016-07-13):
- Resolves #1355963 - installing pki-common causes mode 0755 on /usr/sbin
pki-util-9.0.3-49.el6.noarch [495 KiB] Changelog by Ade Lee (2016-03-14):
- Resolves #1290535 - Check for incompatible Java at startup (pkisilent)
pki-util-9.0.3-45.el6_7.noarch [494 KiB] Changelog by Endi S. Dewata (2016-01-27):
- Resolves #1291747 - Fixed incorrect patch for fixing missing subsystem user on external CA case.
pki-util-9.0.3-43.el6.noarch [494 KiB] Changelog by Endi S. Dewata (2015-05-27):
- Resolves #1225589 - unable to create rhel 7.1 replica from rhel 6 replica CA because subsystem user does not exist
pki-util-9.0.3-39.el6_6.noarch [494 KiB] Changelog by Matthew Harmsen (2015-06-09):
- Resolves #1144608 - pki-core failed to build with cmake-2.8.12.2-4.el6
  (mharmsen - backport for RHEL 6.6.Z)
- Resolves #1037248 - pki-core FTBFS if "-Werror=format-security" flag is used
  (mharmsen - backport for RHEL 6.6.Z)
- Resolves #1243 - Outdated selinux-policy dependency in Dogtag 9
  (mharmsen - backport for RHEL 6.6.Z)
- Resolves #1229361 - ipa-server-install fails when configuring CA
  (edewata - backport for RHEL 6.6.Z)
pki-util-9.0.3-38.el6_6.noarch [493 KiB] Changelog by Matthew Harmsen (2014-09-24):
- Resolves #1144188 - TPS tests: RPM rebuild failure due to wildcard imports
pki-util-9.0.3-37.el6.noarch [493 KiB] Changelog by Ade Lee (2014-07-30):
- Resolves #1123811 - IPA PKI clone certificate renewal produces AVC
pki-util-9.0.3-32.el6.noarch [492 KiB] Changelog by Ade Lee (2013-08-29):
- Resolves #999055 - AVC denials during ipa server and replica installs
- Resolves #998715 - Package Sanity Test Failures
pki-util-9.0.3-30.el6.noarch [491 KiB] Changelog by Ade Lee (2013-01-22):
- Resolves #902474 - upgrading IPA from 2.2 to 3.0 sees certmonger errors
pki-util-9.0.3-24.el6.noarch [491 KiB] Changelog by Ade Lee (2012-03-16):
- BZ 802396 - Change location of TOMCAT_LOG to match tomcat6 changes
pki-util-9.0.3-21.el6_2.noarch [490 KiB] Changelog by Ade Lee (2012-01-17):
- Resolves #771790 - sslget does not work after FEDORA-2011-17400 update,
  breaking FreeIPA install (fixed in Git repo)
pki-util-9.0.3-20.el6.noarch [490 KiB] Changelog by Andrew Wnuk (2011-08-26):
- Resolves #737179 - Need script to upgrade proxy configuration, r2249
pki-util-9.0.3-10.el6.noarch [488 KiB] Changelog by Matthew Harmsen (2011-03-22):
- Resolves #688251 - Dogtag installation under IPA takes too much
  time - SELinux policy compilation, r1908

Listing created by repoview