Linux @ CERN

CERN > IT > Linux

"SLC6X: system environment/libraries: ipa-python

ipa-python - Python libraries used by IPA

Website: http://www.freeipa.org/
License: GPLv3+
Vendor: Scientific Linux CERN, http://cern.ch/linux
Description:
IPA is an integrated solution to provide centrally managed Identity (machine,
user, virtual machines, groups, authentication credentials), Policy
(configuration settings, access control information) and Audit (events,
logs, analysis thereof). If you are using IPA you need to install this
package.

Packages

ipa-python-3.0.0-51.el6.i686 [933 KiB] Changelog by Jan Cholasta (2016-11-07):
- Resolves: #1321138 Missing dependency package "python-sss-murmur" in
  ipa-server-3.0.0-50.el6.x86_64
  - SPEC: Require python2 version of sssd bindings
- Resolves: #1367026 Document and test procedure for running IdM Server in TLS
  1.2+ environment
  - Require 389-ds-base with TLS 1.0 disable switch
ipa-python-3.0.0-50.el6_8.3.i686 [932 KiB] Changelog by Jan Cholasta (2016-08-30):
- Resolves: #1369470 IPA Replica-Install from RHEL6 to RHEL7 Fails
  - Modififed NSSConnection not to shutdown existing database.
  - Do not erroneously reinit NSS in Dogtag interface
  - Make sure replication works after DM password is changed
ipa-python-3.0.0-50.el6_8.2.i686 [932 KiB] Changelog by Jan Cholasta (2016-08-22):
- Resolves: #1351593 CVE-2016-5404 ipa: Insufficient privileges check in
  certificate revocation
  - cert-revoke: fix permission check bypass (CVE-2016-5404)
ipa-python-3.0.0-50.el6.1.i686 [932 KiB] Changelog by Alexander Bokovoy (2016-04-12):
- Update IPA code to support Samba 4.2
- Related: #1322689
ipa-python-3.0.0-47.el6_7.2.i686 [930 KiB] Changelog by Alexander Bokovoy (2016-04-06):
- Update IPA code to support Samba 4.2
- Related: #1322688
ipa-python-3.0.0-47.el6_7.1.i686 [930 KiB] Changelog by Jan Cholasta (2015-11-12):
- Resolves: #1280207 Unable to resolve group memberships for AD users when
  using sssd-1.12.2-58.el7_1.6.x86_64 client in combination with
  ipa-server-3.0.0-42.el6.x86_64 with AD Trust
  - Do not lookup up the domain too early if only the SID is known
  - Do not store SID string in a local buffer
  - Allow ID-to-SID mappings in the extdom plugin
- Resolves: #1280208 ipa-server-install with externally signed CA fails with
  NSS error (SEC_ERROR_BUSY)
  - Free NSS objects in --external-ca scenario
ipa-python-3.0.0-47.el6.i686 [929 KiB] Changelog by Petr Vobornik (2015-05-13):
- Resolves: #1220788 - Some IPA schema files are not RFC 4512 compliant
ipa-python-3.0.0-42.el6.i686 [926 KiB] Changelog by Martin Kosek (2014-07-04):
- Require 389-ds-base >= 1.2.11.15-38 to fix roken dereference control with
  the FreeIPA 4.0 ACIs (#1112698)
ipa-python-3.0.0-37.el6.i686 [923 KiB] Changelog by Martin Kosek (2013-09-30):
- group-add-member command reported wrong error on duplicates (#970541)
- ipa-client installation succeeding in ipa server instance (#1011044)
ipa-python-3.0.0-26.el6_4.4.i686 [921 KiB] Changelog by Martin Kosek (2013-05-20):
- Require 389-ds-base >= 1.2.11.15-14 to pick up fix for CVE-2013-1897
  (#928160)
ipa-python-3.0.0-26.el6_4.2.i686 [921 KiB] Changelog by Martin Kosek (2013-03-01):
- Missing LDAP schema attributeType and objectClass after upgrade (#916535)
- ipa-adtrust-install and ipa-replica-conncheck may not parse krb5.conf
  correctly and crash (#917065)
ipa-python-3.0.0-25.el6.i686 [918 KiB] Changelog by Rob Crittenden (2013-01-29):
- Filter generated winbind dependencies so the right version of samba
  can be installed. (#905594)
ipa-python-2.2.0-17.el6_3.1.i686 [803 KiB] Changelog by Rob Crittenden (2012-12-10):
- Fix changelog issue. The dist tag was in each entry and changing the
  build release changed history. (#878219)
ipa-python-2.2.0-16.el6.i686 [802 KiB] Changelog by Rob Crittenden (2012-05-25):
- SSH Tech Preview feature enabled by default (#825321)
ipa-python-2.1.3-9.el6.i686 [629 KiB] Changelog by Rob Crittenden (2011-11-07):
- Add current password prompt when changing own password in web UI (#751179)
- Remove extraneous trailing ' from netgroup patch (#749352)
ipa-python-2.0.0-23.el6_1.2.i686 [490 KiB] Changelog by Rob Crittenden (2011-09-07):
- Use updated xmlrpc-c API to do GSSAPI ticket delegation (#729805) 
- Set minimum requires of xmlrpc-c to 1.16.24-1200.1840.el6_1.4
- Set minimum requires of libcurl to 7.19.7-26.el6_1.2
ipa-python-2.0.0-23.el6_1.1.i686 [490 KiB] Changelog by Rob Crittenden (2011-05-25):
- Wait for 389-ds tasks to complete (#709329)
- Set replica to restart ipa on boot (#709330)
- Managed Entries not configured on replicas (#709331)
- Don't create bogus aRecord when creating new zone (#709332)
ipa-python-2.0.0-23.el6.i686 [490 KiB] Changelog by Rob Crittenden (2011-04-20):
- Update ipa-Fix-traceback-in-nis-manage.patch to fix python error (#697583)

Listing created by repoview